Skip to content

CVE-2018-7600: Drupalgeddon2

Improper Input Validation: Is CVE-2018-7600 real, exploitable, or a false positive? Here's the community verdict.

Community verdict: No field verdicts yet. Be the first practitioner to weigh in.

signals

public sources

Exploited in wild
Yes
CISA KEV · Nov 3, 2021
Public exploit
Metasploit +2
Metasploit/EDB/PoC
Base severity
9.8 Critical
CVSS
Exploitation prob.
100%
FIRST EPSS
Weakness
CWE-20 · Improper Input Validation
CWE

Confirmed exploited in the wild. Patch this first, regardless of the base score.

cisa ssvc

CISA Vulnrichment · assessed

Exploitation
Active
in the wild
Automatable
Yes
at scale
Technical impact
Total
on success

CISA decision, by how critical the affected system is to you:

  • low impact → Attend
  • medium impact → Act
  • high impact → Act

Track: normal patch cycle · Track*: watch closely · Attend: patch sooner · Act: patch now. About SSVC ↗

public exploits

links to sources — we don’t host code

A working exploit is publicly available from a maintained source. Treat this as higher urgency and verify your exposure.

affected packages

GHSA-7fh9-933g-885p · GitHub rates it critical
  • Composerdrupal/core
    Vulnerable
    ≥ 7.0, < 7.58; ≥ 8.0, < 8.3.9; ≥ 8.4.0, < 8.4.6; ≥ 8.5.0, < 8.5.1
    Fixed in
    7.58, 8.3.9, 8.4.6, 8.5.1
  • Composerdrupal/drupal
    Vulnerable
    ≥ 7.0, < 7.58; ≥ 8.0, < 8.3.9; ≥ 8.4, < 8.4.6; ≥ 8.5, < 8.5.1
    Fixed in
    7.58, 8.3.9, 8.4.6, 8.5.1

Source: GitHub Advisory Database (CC-BY 4.0), via OSV.dev. Check your lockfile version against the ranges above.

baseline read

auto · not a community verdict

Real — exploited in the wild

CISA confirms active exploitation. Treat scanner hits as true positives unless your specific version or config is unaffected.

Based on CISA KEV

Confirm or dispute →
Affected:DrupalDebian

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6, and 8.5.x before 8.5.1 allows remote attackers to execute arbitrary code because of an issue affecting multiple subsystems with default or common module configurations.

Published · Added to CISA KEV (1315 days after publication)

Embed this verdict
TruePositive verdict for CVE-2018-7600
Markdown
[![TruePositive verdict](https://www.truepositive.app/cve/CVE-2018-7600/badge.svg)](https://www.truepositive.app/cve/CVE-2018-7600)
HTML
<a href="https://www.truepositive.app/cve/CVE-2018-7600"><img src="https://www.truepositive.app/cve/CVE-2018-7600/badge.svg" alt="TruePositive verdict for CVE-2018-7600"></a>

Live badge that updates automatically as the community verdict changes.

timeline

  1. CISA SSVC assessment · exploitation: active
  2. Added to CISA KEV · confirmed exploited in the wild
  3. Added to VulnCheck KEV · reported exploited in the wild
  4. Published by NVD

Score and exploit changes tracked since .

Community ground truth

Be the first practitioner to weigh in

So far this is only TruePositive's editorial baseline from public sources. Add your real-world verdict below — it becomes the signal the next person triaging this relies on.

🥇 The first 50 practitioners to contribute earn a Founding Contributor badge.

In your experience, is this finding real and exploitable?

awaiting field verdicts
Real, but not a risk here
Not a real issue

Curated baseline: TruePositive's read from public sources is Real & exploitable — a starting point, not a community verdict.

No account needed. Anonymous verdicts post as an unverified signal. Log in to make yours verified and earn reputation.

Field notes & remediation

Verdicts are the quick signal. Notes are the evidence and fixes behind them.

  • 0
    Field note · TruePositive EditorialCurated

    An unauthenticated attacker can run code on a Drupal site by abusing how the Form API processes render arrays in request data. Public exploits appeared within days, and attackers mass-deployed cryptominers and web shells.

    Who is affected: Drupal 7 and 8 core before the fixed versions, especially internet-facing sites.

    How to check: find the Drupal core version. If you ran an unpatched Drupal 7 or 8 site during 2018, assume it was hit and look for signs of compromise.

    Commonly flagged by: Nessus, Qualys, Rapid7.

  • 0
    Remediation · TruePositive EditorialCurated

    Update Drupal core to 7.58 or 8.5.1 or later (go to the latest supported release, since there were follow-up fixes). After updating, audit for dropped miners and web shells, and rotate site secrets and admin credentials, because this was widely exploited.

Add a field note or remediationoptional
Note type

What are you adding?

Markdown supported · minimum 20 characters.

Same weakness: CWE-20 · Improper Input Validation.